Back to overview
Resolved

MMS outage

Jul 10, 2026 at 5:00pm UTC
Affected services
Web Application

Resolved
Jul 11, 2026 at 10:19am UTC

The failures were caused by a connectivity issue with an upstream carrier partner, which has since been restored.

Created
Jul 10, 2026 at 5:00pm UTC

Our primary service provider for MMS messaging is experiencing a global outage. We're working with them for updates and resolution.